rss
  •  

Расчет средневзвешенного

| Категория: Приемы и советы, Формулы и функции |

4

Во всех версиях есть функция, позволяющая вычислять среднее арифметическое — это функция СРЗНАЧ [AVERAGE].

srvzv1.png

В данном случае видно, что вряд ли подобное значение может быть похоже на среднее значение ежедневного пробега. Отсюда и возникает необходимость рассчитывать и средневзвешенное, т.е. среднее значение в перерасчете на фактор-единицу, например, день. Подобной функции в Excel нет. Тем не менее, можно вычислить, используя математические функции.

1-й способ: СУММПРОИЗВ [SUMPRODUCT] и СУММ [SUM].

Необходимо перемножить каждый пробег на количество дней, за которые он был указан, а затем разделить на общее количество дней:

srvzv2.png

=СУММПРОИЗВ(A3:A11;B3:B11)/СУММ(B3:B11) или =SUMPRODUCT(A3:A11;B3:B11)/SUM(B3:B11)

2-й способ: СУММ [SUM] и формула массива.

Сперва вводится обычная формула, а затем завершается нажатием на клавиши CTRL+SHIFT+ALT (в результате в формуле появляются фигурные скобки — признак формулы массива).

srvzv3.png

 {=СУММ(A3:A11*B3:B11)/СУММ(B3:B11)} или {=SUM(A3:A11*B3:B11)/SUM(B3:B11)}

В случае, если расчет средневзвешенного нужно произвести по более сложным формулам, то 2-й способ с использованием формулы массива дает больше гибкости в вычислениях.




Оставьте комментарий!

На сообщение “Расчет средневзвешенного” комментария 4

  1. Ярослав:

    Хорошие варианты решения, причем оба

  2. Pingvinka:

    Благодаря этой статье я узнала о формулах массива и смогла применить для своей задачи совсем другой тематики. И это прекрасно!

  3. Марат:

    Решал другую задачу, но смысл был очень похож. Формула массива — это ВЕЩЬ!

  4. НаталиКо:

    А я все искала одну формулу, чтобы она мне подсчитала 🙂