rss
  •  

Прибавляем/отнимаем к дате годы

| Категория: Приемы и советы, Формулы и функции |

0

Каждая дата в Excel соответствует целому положительному числу. Задачи по определению даты, которая наступит через указанное количество дней, решаются с помощью простых математических действий. Однако, вычисления могут быть не только с днями, но и с годами – в этом случае необходимо использовать функции.

Например, есть дата продажи товара, необходимо определить дату до которой действует гарантийный срок.

datesumyear1.png

Для решения этой задачи необходимо воспользоваться 4 функциями из категории Дата и время:

  • ДЕНЬ(Дата_в_числовом_формате) – определяет число месяца: число от 1 до 31.
    DAY(Serial_number)
  • МЕСЯЦ(Дата_в_числовом_формате) – определяет месяц: число от 1 (январь) до 12 (декабрь).
    MONTH(Serial_number)
  • ГОД(Дата_в_числовом_формате) – определяет год: целое число от 1900 до 9999.
    YEAR(Serial_number)
  • ДАТА(Год;Месяц;День) – получение даты по исходным данным, таким как день, месяц и год.
    DATE(Year;Month;Day)

Функции ДЕНЬ, МЕСЯЦ и ГОД позволят разобрать дату на составляющие, к составляющей ГОД прибавим гарантийный срок, а функцией ДАТА соберем из составляющих дату:

datesumyear2.png

Сумма с накоплением

| Категория: Приемы и советы, Формулы и функции |

3

При расчете суммы с накопительным итогом нужно понимать, что сумма каждой следующей записи (дня) соответствует сумме, где собраны слагаемые всех предыдущих записей (дней).

runningsum1.png
Вычисление сумм с накоплением (сумм с нарастающим итогом) можно осуществлять в несколько действий, однако можно написать и одну простую формулу, используя функцию СУММ (SUM) и различный вид ссылок на адреса ячеек.
Формула в первой записи будет иметь вид: =СУММ($B$2:B2) или =SUM($B$2:B2), где ссылка на первую ячейку диапазона $B$2 является абсолютной (расчет любого итогового значения должен всегда идти от первой записи), а ссылка на последнюю ячейку диапазона B2 – относительной (диапазон должен автоматически увеличиваться при копировании формулы вниз).

runningsum2.png

Формат даты с указанием дня недели

| Категория: Приемы и советы, Форматирование |

2

Сперва смотрим в ячейку и затем в календарь, чтобы увидеть соответствующий день недели?
Применение пользовательского формата позволит решить такую задачу в считанные мгновения.

formatcellsdate1.png
Выделить ячейки диапазона дат – C3:D12, зайти в окно Формат ячеек [Format cells], нажав клавиши Ctrl+1.

Выбрать числовой формат (все форматы) [Custom] и в поле Тип [Type] ввести:

formatcellsdate3.png
Данный формат состоит из 2-х частей, разделенных между собой пробелом.
1-я часть — формат, показывающий день недели в 2-х буквенном обозначении (Пн, Вт, Ср и т.д.)
2-я часть – формат даты (01.03.2013)

formatcellsdate2.png