rss
  •  

ВПР и ДВССЫЛ: в любом месте лучше вместе!

| Категория: Приемы и советы, Формулы и функции |

2

Задачи по сбору информации с разных листов в одну консолидированную таблицу встречаются постоянно:

Исходные данные выглядят однотипно, Например, на каждом листе в столбце А находятся Фамилии, а в столбце В — Количество заказов. Причем на каждом листе фамилии могут располагаться в разном порядке:

Знание функций ВПР [VLOOKUP] и ДВССЫЛ [INDIRECT] существенно облегчает решение данной задачи:

=ВПР(C$1;ДВССЫЛ($B2&»!A:B»);2;0)  или в англоязычной версии:
=VLOOKUP(C$1;INDIRECT($B2&»!A:B»);2;0)

Функция ДВССЫЛ позволяет управлять адресом диапазона не путем обычного выделения, а путем формирования из 2-х частей: названия листа и диапазона!

Больше знаний — быстрее решение!

Написание формул в несколько строк

| Категория: Приемы и советы, Формулы и функции |

1

Потребность в написании формул в несколько строк может быть продиктована желаем более удобно её читать и быстрее понимать алгоритм вычисления, а при необходимости и редактировать формулу.

При обычном вводе формулы всё прописывается в одну строку, а при условии, что формула «длинная», происходит перемещение символов  на следующую строку по мере не хватки места в предыдущей. И такая формула не всегда наглядна и легка для понимания:

Чтобы добавить наглядности, можно принудительно ставить разрывы строк, используя комбинацию клавиш Alt+Enter, при необходимости увеличить отступ слева:

И пусть Ваши формулы будут наглядными 🙂

Автозавершение формул

| Категория: Приемы и советы, Формулы и функции |

4

Все уже привыкли, что в Excel присутствует автозавершение формул — это удобно, а к хорошему быстро привыкаешь. Достаточно ввести первые символы — программа предложит список функций, начинающиеся с этих символов.

Если в один прекрасный момент вы заметили, что автозавершение формул пропало, то стоит изменить настройку:

Открыть Файл [File], выбрать Параметры [Options], затем Формулы [Formulas], установить флажок Автозавершение формул [Formula AutoComplete]