rss
  •  

Сумма при множестве условий

| Категория: Приемы и советы, Формулы и функции |

0

Начиная с 2007 версии, в программе есть функция СУММЕСЛИМН [SUMIFS], с помощью которой можно осуществить сложение максимум при 127 условиях. Однако, эти условия должны выполняться одновременно.
Например, необходимо вычислить сумму по полю Стоимость партии, р при условии, что поставки были в мае по кофеваркам и кофемолкам от поставщика БытТехСила, а в июне — по чайникам и тостерам от всех поставщиков. В таблице присутствуют данные за весь год.

Необходимо подготовить таблицу с условиями. Принцип формирования как при работе с Расширенным фильтром:

БДСУММ [DSUM]
База_данных [Datebase] — таблица-источник, выделить диапазон с заголовками
Поле [Field] — имя поля таблицы, можно задать как текстовое значение или номер столбца таблицы
Критерий [Criteria] — таблица условий, выделить вместе с заголовками

=БДСУММ(A:G;F1;I2:L6)

[=DSUM(A:G;F1;I2:L6)]

При изменении данных в таблице или условий в таблице условий, результат будет автоматически рассчитан. Если будет существенное изменение в таблице условий, то в формуле диапазон условий нужно определить заново.

ВПР и ДВССЫЛ: в любом месте лучше вместе!

| Категория: Приемы и советы, Формулы и функции |

3

Задачи по сбору информации с разных листов в одну консолидированную таблицу встречаются постоянно:

Исходные данные выглядят однотипно, Например, на каждом листе в столбце А находятся Фамилии, а в столбце В — Количество заказов. Причем на каждом листе фамилии могут располагаться в разном порядке:

Знание функций ВПР [VLOOKUP] и ДВССЫЛ [INDIRECT] существенно облегчает решение данной задачи:

=ВПР(C$1;ДВССЫЛ($B2&»!A:B»);2;0)  или в англоязычной версии:
=VLOOKUP(C$1;INDIRECT($B2&»!A:B»);2;0)

Функция ДВССЫЛ позволяет управлять адресом диапазона не путем обычного выделения, а путем формирования из 2-х частей: названия листа и диапазона!

Больше знаний — быстрее решение!

Написание формул в несколько строк

| Категория: Приемы и советы, Формулы и функции |

1

Потребность в написании формул в несколько строк может быть продиктована желаем более удобно её читать и быстрее понимать алгоритм вычисления, а при необходимости и редактировать формулу.

При обычном вводе формулы всё прописывается в одну строку, а при условии, что формула «длинная», происходит перемещение символов  на следующую строку по мере не хватки места в предыдущей. И такая формула не всегда наглядна и легка для понимания:

Чтобы добавить наглядности, можно принудительно ставить разрывы строк, используя комбинацию клавиш Alt+Enter, при необходимости увеличить отступ слева:

И пусть Ваши формулы будут наглядными 🙂