rss
  •  

Ввод цифры, а отображение текстом

| Категория: Приемы и советы, Работа с данными ячеек, Форматирование |

0

Требуется в ячейки осуществлять ввод чисел, например, от 1 до 5; вычислять среднее значение по числовым данным, при этом вместо цифр в ячейках должны присутствовать слова, например, 5 — отлично; 4 — хорошо; 3- удовлетворительно и т.д.

1. Создать список для выбора чисел в ячейках — выделить ячейки, на вкладке Данные [Data] в группе Работа с данными [Data Tools] выбрать Проверка данных [Data Validation], тип данных —  список [List], в поле Источник [Source] ввести 1;2;3;4;5 (разделитель такой же, как разделитель в аргументах функций)

2. Теперь нужно реализовать «зрительное» преобразование чисел в текст. Для этого воспользуемся условным форматированием с установкой пользовательского формата.
Выделить ячейки, на вкладке Главная [Home] в группе Стили [Styles] выбрать Условное форматирование [Condition Formatting] выбрать Правила выделения ячеек [Highlight Cells Rules]- Равно [Equal To]. Ввести число, например, 5. Чтобы задать нужный формат представления информации выбрать Пользовательский формат [Custom Format], на вкладке Число [Number] выделить Числовой формат [Category] —  (все форматы) [Custom] и в поле Тип [Type] ввести нужный текст в кавычках — «отлично». По аналогии создать и другие правила для отображения других чисел.

Теперь при выборе числа из списка или ручном вводе, вместо числа будет отображаться текст!

ВПР и ДВССЫЛ: в любом месте лучше вместе!

| Категория: Приемы и советы, Формулы и функции |

2

Задачи по сбору информации с разных листов в одну консолидированную таблицу встречаются постоянно:

Исходные данные выглядят однотипно, Например, на каждом листе в столбце А находятся Фамилии, а в столбце В — Количество заказов. Причем на каждом листе фамилии могут располагаться в разном порядке:

Знание функций ВПР [VLOOKUP] и ДВССЫЛ [INDIRECT] существенно облегчает решение данной задачи:

=ВПР(C$1;ДВССЫЛ($B2&»!A:B»);2;0)  или в англоязычной версии:
=VLOOKUP(C$1;INDIRECT($B2&»!A:B»);2;0)

Функция ДВССЫЛ позволяет управлять адресом диапазона не путем обычного выделения, а путем формирования из 2-х частей: названия листа и диапазона!

Больше знаний — быстрее решение!

Написание формул в несколько строк

| Категория: Приемы и советы, Формулы и функции |

1

Потребность в написании формул в несколько строк может быть продиктована желаем более удобно её читать и быстрее понимать алгоритм вычисления, а при необходимости и редактировать формулу.

При обычном вводе формулы всё прописывается в одну строку, а при условии, что формула «длинная», происходит перемещение символов  на следующую строку по мере не хватки места в предыдущей. И такая формула не всегда наглядна и легка для понимания:

Чтобы добавить наглядности, можно принудительно ставить разрывы строк, используя комбинацию клавиш Alt+Enter, при необходимости увеличить отступ слева:

И пусть Ваши формулы будут наглядными 🙂