rss
  •  

ВПР и ДВССЫЛ: в любом месте лучше вместе!

| Категория: Приемы и советы, Формулы и функции |

3

Задачи по сбору информации с разных листов в одну консолидированную таблицу встречаются постоянно:

Исходные данные выглядят однотипно, Например, на каждом листе в столбце А находятся Фамилии, а в столбце В — Количество заказов. Причем на каждом листе фамилии могут располагаться в разном порядке:

Знание функций ВПР [VLOOKUP] и ДВССЫЛ [INDIRECT] существенно облегчает решение данной задачи:

=ВПР(C$1;ДВССЫЛ($B2&»!A:B»);2;0)  или в англоязычной версии:
=VLOOKUP(C$1;INDIRECT($B2&»!A:B»);2;0)

Функция ДВССЫЛ позволяет управлять адресом диапазона не путем обычного выделения, а путем формирования из 2-х частей: названия листа и диапазона!

Больше знаний — быстрее решение!